66 mustang light switch wiring 1966 Mustang Interior Lights, Windshield Wiper, Gauges · Schematic 8 Professional 66 Mustang Light Switch Wiring Photos

8 Professional 66 Mustang Light Switch Wiring Photos

Galleries photos in this diagram:

Other recommended photos you might like:

1966 Mustang Interior Lights, Windshield Wiper, Gauges · Schematic - Specifications... 1965 coupe 289 with lamps. So i've been doing a number of work on my vehicle the beyond 6 weeks and i've a wiring haywire somewhere. First of all, the car starts offevolved nice, runs first-rate, lights paintings, brights paintings, tail lights work, reverse lighting work, parking lamps paintings, horn works. I've introduced the following new parts. New tail light package (housing, bulbs, chrome, etc.) New backup lamp package new parking lamp package new primary wiring harness from mr. Mustang; the main headlight transfer wiring harness (voltage reg, lighting, park lights, horns, alternator, solenoid) new major wiring harness for the engine (temp sending unit, oil sending unit, two velocity fan, ignition, coil, and many others.) New autolite voltage regulator rebuilt the fuse field with shiny new connectors and fuses. New alternator wiring harness to in shape original that plugs in to the headlight wiring harness and attaches to the nice side of solenoid new starter new scott drake regular voltage regulator at the again of the inst panel. New flexplate (flywheel) new impartial safety switch battery has been fully charged at the neighborhood autozone alternator passes the test (two times) achieved at autozone so here is/are the issue(s) 1. The alt lamp remains on constantly. There is no sign of battery drain as i'm able to drive round metropolis, prevent, start again, depart it for 4 days and exit and start it again. 2. After i switch the important thing to the "on" function, the left turn sign works first-rate. After i put the right turn signal on, each rear taillights flash as though it have been the use of hazard lighting fixtures (which i don't have). Three. After i switch the important thing inside the "on" role and activate the parking lamps, the left turn signal works excellent. After i turn on the right flip sign. The flip signal mild comes on and remains lit. The right tail mild and park lamp come on as though it desires to flash, however it stays vivid. At the identical time, the left tail lamp dims just a piece but nevertheless stays lit as it's in the parking lamp position. 4 when i switch the key within the "on" function and activate the lighting, the same thing takes place as explained in #three ***right here is where it starts getting bizarre*** five. If i leave the important thing in the off function and no longer actually have it in the ignition, not anything happens left or proper, glaringly 6. If i depart the important thing inside the off position and no longer even have it within the ignition, and flip the parking lamps on after which the left flip signal, not anything occurs except the left tail mild dims a piece. But if i switch on the proper turn sign, the left rear tail light dims a piece and then the oil light comes on (yeah.. Head scratcher). And to make that greater bizarre, if the fan is within the low or high function, it will make the oil mild blink and the heater fan start pulsating within the same rhythm because the turn signal noise. 7. The identical factor takes place because it did in #6 if i depart it in the off position, now not have the key in it, turn the lighting fixtures all the manner on. The left tail lamp will dim a chunk and the oil lamp will come on. And if the heater is on, it's going to make the oil light and heater fan blink/turn on in unison with the flip signal flasher. Obviously there is a wiring mix up right here, but i'm able to't seem to discover it. I am decently professional on the subject of running on this vehicle as it's so mechanical and the wiring is quite simple, but this has stumped me. Does all and sundry have any thoughts of wherein first of all this? I have a sense that once the offender is determined, the alt light will burst off, the oil light will stop flashing and all will be again to regular. That's how it seems to go with this automobile. Again, starts first-rate, drives best, however this difficulty is weird and confusing. All of the fuses within the newly rebuilt fuse block are nevertheless top, however maybe i shouldn't rule out a mis-twine on the fuse block. However if that have been the case, i'd think there would be lots bigger and major problems. I have now not changed the flip sign 2 prong plug due to the fact i have in no way had an trouble earlier than this. In order that is not new.